Как установить Zend Optimizer?

Если не нашли подходящего форума - задайте вопрос здесь

Модераторы: Art.i, garry

Сообщение speakforum » Пт янв 22, 2010 4:16 am

А где файл создавать, с каким именем?
speakforum
 
Сообщений: 155
Зарегистрирован: Вс дек 27, 2009 12:47 pm

Сообщение ls » Пт янв 22, 2010 5:59 am

В директории www домена с именем вида file.php и потом соответственно открыть его браузером

А вообще, лучше вам написать тикет в тех.поддержку, определить по-другому в чем у вас проблема затруднительно.
ls
Support team
 
Сообщений: 6397
Зарегистрирован: Чт мар 01, 2007 10:36 am
Откуда: FirstVDS

Сообщение speakforum » Пт янв 22, 2010 7:56 am

Готово! Он мне выдал инфо о сервере.
speakforum
 
Сообщений: 155
Зарегистрирован: Вс дек 27, 2009 12:47 pm

Сообщение ls » Пн янв 25, 2010 7:08 pm

В этой информации Zend Optimizer виден? Если да - значит поставился нормально и причина не работы в чем-то другом.
ls
Support team
 
Сообщений: 6397
Зарегистрирован: Чт мар 01, 2007 10:36 am
Откуда: FirstVDS

Сообщение G » Пт апр 09, 2010 5:48 am

Для установки на FreeBSD 8 достаточно сделать

cd /usr/ports/devel/ZendOptimizer/
make install clean

затем
Пропишите в /usr/local/etc/php/extensions.ini то что он скажет написать и перезапустите Apache.

обычно он скажет что-то вроде этого

[Zend]
zend_optimizer.optimization_level=15
zend_extension_manager.optimizer="/usr/local/lib/php/20060613/Optimizer"
zend_extension_manager.optimizer_ts="/usr/local/lib/php/20060613/Optimizer_TS"
zend_extension="/usr/local/lib/php/20060613/ZendExtensionManager.so"
zend_extension_ts="/usr/local/lib/php/20060613/ZendExtensionManager_TS.so"

перезагруз и опля все работает :) правда только 3.3.0 версия будет.
G
 
Сообщений: 9
Зарегистрирован: Ср сен 23, 2009 6:53 am
Откуда: Новосибирск

Сообщение ls » Пт апр 09, 2010 5:54 am

Новее чем 3.3.0 не существует под FreeBSD 8.0 amd64 которая используется на виртуальных серверах.
ls
Support team
 
Сообщений: 6397
Зарегистрирован: Чт мар 01, 2007 10:36 am
Откуда: FirstVDS

Сообщение Captain » Ср апр 21, 2010 4:25 pm

Переустановил FreeBSD 8, до этого ZendOptimizer нормально устанавливал, теперь выдается ошибка что мол 3.3.0.a не поддерживает php5
===> ZendOptimizer-3.3.0.a cannot install: doesn't work with PHP version : 5 (Doesn't support PHP 5).
*** Error code 1
Captain
 
Сообщений: 107
Зарегистрирован: Вт авг 18, 2009 4:20 pm

Сообщение ls » Ср апр 21, 2010 7:00 pm

Посмотрите сообщение от меня в этой теме http://forum.firstvds.ru/viewtopic.php?t=1360
Ставьте более старую версию порта, ссылку на него я там привожу
ls
Support team
 
Сообщений: 6397
Зарегистрирован: Чт мар 01, 2007 10:36 am
Откуда: FirstVDS

Сообщение Captain » Ср апр 21, 2010 7:32 pm

ls,
Спасибо большое, установил.
Captain
 
Сообщений: 107
Зарегистрирован: Вт авг 18, 2009 4:20 pm

Сообщение jeykey » Чт июн 03, 2010 11:52 pm

G писал(а):Для установки на FreeBSD 8 достаточно сделать

cd /usr/ports/devel/ZendOptimizer/
make install clean

затем
Пропишите в /usr/local/etc/php/extensions.ini то что он скажет написать и перезапустите Apache.

обычно он скажет что-то вроде этого

[Zend]
zend_optimizer.optimization_level=15
zend_extension_manager.optimizer="/usr/local/lib/php/20060613/Optimizer"
zend_extension_manager.optimizer_ts="/usr/local/lib/php/20060613/Optimizer_TS"
zend_extension="/usr/local/lib/php/20060613/ZendExtensionManager.so"
zend_extension_ts="/usr/local/lib/php/20060613/ZendExtensionManager_TS.so"

перезагруз и опля все работает :) правда только 3.3.0 версия будет.



спасибо все получилось, зенд 3.0 а хочеться 3.3.0
jeykey
 
Сообщений: 1
Зарегистрирован: Вт июн 01, 2010 11:01 pm

Сообщение ls » Пт июн 04, 2010 5:27 am

3.3.0.a и ставится на самом деле, новее чем в порте не существует для системы FreeBSD amd64
* FirstVDS в twitter в facebook и в вконтакте *
ls
Support team
 
Сообщений: 6397
Зарегистрирован: Чт мар 01, 2007 10:36 am
Откуда: FirstVDS

Сообщение moderator » Ср июн 23, 2010 1:32 pm

G писал(а):Для установки на FreeBSD 8 достаточно сделать


Спасибо, все установилось.
moderator
BANNED
 
Сообщений: 8
Зарегистрирован: Пн июн 14, 2010 2:14 pm

Сообщение G » Пт дек 03, 2010 11:23 pm

Установка Zend Optimizer 3.3.9 на Сentos (linux)

Перейдем в директорию /tmp:
cd /tmp
Загрузим на сервер (32б)
wget http://downloads.zend.com/optimizer/3.3 ... 386.tar.gz
Распаковываем:
tar -xzf ZendOptimizer-3.3.9-linux-glibc23-i386.tar.gz
cd ZendOptimizer-3.3.9-linux-glibc23-i386
Копируем файл для версии версии php - обычно самое правильное это скопировать вручную но можно попробовать вот так
cp -rfv data/5_2_x_comp/ZendOptimizer.so /usr/local/Zend/lib
В файл /etc/php.ini вносим строки в секцию [Zend]:

[Zend]
zend_extension=/usr/local/Zend/lib/ZendOptimizer.so


Перезапускаем Apache командой:
# service httpd restart
G
 
Сообщений: 9
Зарегистрирован: Ср сен 23, 2009 6:53 am
Откуда: Новосибирск

Re:

Сообщение max3d+ » Сб ноя 14, 2015 10:03 am

speakforum писал(а):Я понял в чем ошибка, все исправил, вроде установился.

Привет подскажи пожалуйста в чем была ошибка а то такая же проблема сообразить вообще не могу
max3d+
 
Сообщений: 1
Зарегистрирован: Сб ноя 14, 2015 10:00 am

Пред.

Вернуться в Любые вопросы

Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 4