Обновление PHP

Все о скриптах

Модераторы: Art.i, vasya

Обновление PHP

Сообщение angarsk3 » Пн сен 02, 2013 1:24 pm

Планируется ли Обновление PHP сейчас стоит версия 5.2.4 а сейчас уже есть как мне известно 5.4
Сейчас даже Joomla 3 не устанавливается !
Мои сайты на FirstVds
Новости:http://gigaz.ru Биржа ссылок:http://slotlink.ru Реалтоны:http://abdj.ru Магазин: http://gnbinfo.ru
angarsk3
 
Сообщений: 7
Зарегистрирован: Вс апр 29, 2012 6:44 am

Re: Обновление PHP

Сообщение ls » Пн сен 02, 2013 7:51 pm

На всех новых серверах PHP 5.4 (FreeBSD-9-ISPmanager) или PHP 5.3 (Debian 6 / CentOS 6 / Ubuntu 12.04), на старых версия PHP менять не будет.
* FirstVDS в twitter в facebook и в вконтакте *
ls
Support team
 
Сообщений: 6405
Зарегистрирован: Чт мар 01, 2007 10:36 am
Откуда: FirstVDS

Re: Обновление PHP

Сообщение amsg » Чт сен 19, 2013 2:40 am

Печально. Вообще, печальный хостинг. Ничего это не аналог выделенного сервера. Я сам даже ПО толком обновить не могу, а тут чуть не каждый год меняют версию ОС и "счастливые" обладатели предыдущих идут лесом, могут заказывать новые сервера, потеряв все айпишники и прочее, к чему всё привязано было, надолго заковырявшись с восстановлением данных и настроек, чтобы через некоторое время заново всё это проделывать уже с новой версией. Вообще, друзья-товарищи, это всё уже есть повод обратиться за защитой прав потребителей по причине оказания услуг ненадлежащего качества. Хостинг-провайдер, к тому же, действуя на основании публичной оферты даёт преимущество одним пользователям перед другими. Когда невозможно поставить веб-портал из-за того, что хостинг-провайдер отказывается обновлять ПО сервера и есть некачественное оказание услуг.
©
amsg
 
Сообщений: 94
Зарегистрирован: Вт авг 01, 2006 2:05 am
Откуда: Москва

Re: Обновление PHP

Сообщение ls » Чт сен 19, 2013 4:12 am

То есть вы предлагаете, чтобы мы поменяли версию PHP на старых серверах (FreeBSD 8) и у всех все упало так как до сих пор ежедневно в поддержке я вижу тикеты когда людям с новым PHP 5.4 требуется поставить старый PHP 5.2 для работы их старых скриптов.
Версии 5.2 и 5.4 не совместимы и поэтому старые сервера не трогаются и не будут трогаться, ставятся только обновления в пределах текущей ветки на виртуализации VDSmanager-FreeBSD (это модифицированный jail и там VDS состоит из файлов шаблона который разработчики (ISPsystem) обновляют).
На технологии виртуализации KVM/OpenVZ все файлы полностью ваши и там можете производить любые действия (кстати, тем что файлы там никак не затрагиваются я даже считаю более правильно)

Возьмите сервер с нужным вам набором ПО. Считаю данный вопрос исчерпаным. Лучше на KVM - аппаратная виртуализация - аналог выделенного сервера где сами как угодно обновляется что на что вам нужно.
* FirstVDS в twitter в facebook и в вконтакте *
ls
Support team
 
Сообщений: 6405
Зарегистрирован: Чт мар 01, 2007 10:36 am
Откуда: FirstVDS

Re: Обновление PHP

Сообщение otec » Чт сен 19, 2013 11:15 pm

amsg писал(а):Когда невозможно поставить веб-портал из-за того, что хостинг-провайдер отказывается обновлять ПО сервера и есть некачественное оказание услуг.

Как правильно заметил ls, ради вас одного никто не будет ронять ресурсы всех остальных пользователей, кто использует более ранние версии php. Хотите сами всем рулить - берите виртуализацию kvm.
otec
 
Сообщений: 331
Зарегистрирован: Чт апр 30, 2009 3:16 pm

Re: Обновление PHP

Сообщение lamnya » Пт сен 20, 2013 3:15 am

Можно и на FreeBSD так сделать. Запускаете команду:
find / -exec touch {} \;
После этого все файлы на vds не шаблонные и ПО не будет обновляться централизовано.
Обновляете что нужно и пользуетесь и обновление ПО в шаблоне вам не помешает.
Места больше на диске будет заниматься чем до этого, так как шаблонные файлы в квоту не считаются.
lamnya
 
Сообщений: 185
Зарегистрирован: Сб ноя 05, 2011 5:18 am


Вернуться в CGI, Perl, PHP

Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 4