Страница 1 из 1

Zend 3.3.3/3.3.9

СообщениеДобавлено: Вт фев 28, 2012 1:24 pm
bpar
Здравствуйте,

У меня BSD8 на которую я хочу поставить HostCMS. PHP у нас из шаблона, то есть 5.2.17, в то время как PHP 5.2.10 и выше конфликтует с Zend'ом до версии 3.3.0. Соответственно, нужен Zend версией 3.3.4/3.3.9.

В портах у вас он - 3.3.3, а на zend.com говорят, что последняя версия PHP которую будет поддерживать Zend на BSD это 5.3, да и то только на 32-х битных системах.

Как быть?

Re: Zend 3.3.3/3.3.9

СообщениеДобавлено: Вт фев 28, 2012 1:32 pm
bpar
И кстати, что самое главное...

uname -a
FreeBSD ecotust.ru 8.2-STABLE FreeBSD 8.2-STABLE #0 r112:113: Mon Dec 19 08:17:00 IRKT 2011 root@freebsd8-amd64.ispsystem.net:/root/src/sys/amd64/compile/ISPSYSTEM amd64

64-х битная же VDS! Как быть-то???

Re: Zend 3.3.3/3.3.9

СообщениеДобавлено: Вт фев 28, 2012 1:52 pm
devisp
По-моему, здесь только на серверах с Linux стоят 32-битные системы.

Re: Zend 3.3.3/3.3.9

СообщениеДобавлено: Вт фев 28, 2012 2:13 pm
bpar
Ошибаетесь!

uname -m
amd64

Re: Zend 3.3.3/3.3.9

СообщениеДобавлено: Вт фев 28, 2012 3:53 pm
bpar
В общем, граждане-товарищи юзеры и администраторы... Зенда 3.3.9 под архитектуру amd64 для BSD нет, и по всей видимости, не будет. Получается, что либо откатываться на PHP 5.2.9, или искать порт Зенда 3.3.4, который вроде как должен быть для i386, как подсказывает мне мое чутье...

К слову сказать, фря уже почти труп... Хотел поставить Debian 6.0, но из ваших шаблонов он не поставляется с ISPManager'ом, только Debian 5, который непонятно ***** какого все еще имеется в списке предлагаемых, не смотря на то, что поддержка его уже прекратилась...

Re: Zend 3.3.3/3.3.9

СообщениеДобавлено: Вт фев 28, 2012 4:06 pm
bpar
Еще одна большая загадка, зачем вашим VDS'ам с таким объемом памяти быть 64-битными?

Re: Zend 3.3.3/3.3.9

СообщениеДобавлено: Вт фев 28, 2012 4:13 pm
bpar
Как думаете, господа-админы, может порт-даунгрейднуться на php 5.2.9? У вас тут такие костыли разрешены?

p.s. Странное какое-то чувство возникает... будто бы я разговариваю сам с собой...

Re: Zend 3.3.3/3.3.9

СообщениеДобавлено: Вт фев 28, 2012 6:07 pm
ls
Возьмите VDS на CentOS 5, там PHP 5.1.6 и 32 битная система и думаю подойдет Zend нужной версии.
Что касается Debian 6 / Ubuntu 10 то там уже давно PHP 5.3. Шаблон с Debian 6 с ISPmanager скоро будет (как разработчики VDSmanager его сделают)

32 битную FreeBSD можно поставить на VDS на виртуализации Xen

Re: Zend 3.3.3/3.3.9

СообщениеДобавлено: Вт фев 28, 2012 8:17 pm
bpar
К сожалению, я не люблю Redhat-like дистрибутивы.
А насчет Debian 6 и Ubuntu 10 - они должны подойти, так как как я понимаю, дело не в PHP 5.3 а в том, то компания Zend больше не собирается поддерживать их продукты для FreeBSD.

Re: Zend 3.3.3/3.3.9

СообщениеДобавлено: Вт фев 28, 2012 9:46 pm
ls
В таком случае самый реальный вариант на сегодня - поставить сервер на Ubuntu 10.04, затем проинсталлировать на него ISPmanager (в установке по-умолчанию все ставится без проблем)
Лицензия ISPmanager Lite есть на все наши адреса, инструкция по установке в документации разработчиков ПО

Re: Zend 3.3.3/3.3.9

СообщениеДобавлено: Ср фев 29, 2012 1:38 pm
bpar
ls писал(а):В таком случае самый реальный вариант на сегодня - поставить сервер на Ubuntu 10.04, затем проинсталлировать на него ISPmanager (в установке по-умолчанию все ставится без проблем)

Почему пресет с Debian 6 не подойдет для моих потребностей? Там тоже имеет место быть конфликт версий PHP с Zend Optimizer?

Re: Zend 3.3.3/3.3.9

СообщениеДобавлено: Ср фев 29, 2012 6:42 pm
ls
Debian 6 также подойдет

Re: Zend 3.3.3/3.3.9

СообщениеДобавлено: Пт мар 02, 2012 11:27 am
bpar
Последний вопрос:

На данный момент шаблон пресета Debian 6 без ISPManager. Если я перейду на него, то после того, как разработчики ISPManager создадут шаблон Debian 6 с ISPManager, он автоматически будет мне доступен, или так же потребуется переустановка VDS?

Re: Zend 3.3.3/3.3.9

СообщениеДобавлено: Пт мар 02, 2012 5:04 pm
ls
Потребуется переустановка VDS