"шаблонный" PHP5 без обновлений уже пол-года!

Все о скриптах

Модераторы: Art.i, vasya

"шаблонный" PHP5 без обновлений уже пол-года!

Сообщение driveparty » Сб фев 18, 2012 4:04 pm

Очень странный "цикл" обновляемости PHP5 в "шаблонах" для BSD-виртуализации: установленный 5.3.8 выпущен пол-года назад, обновления до 5.3.9 в январе и 5.3.10 в феврале (оба с security bugfixes, последний – с довольно серьёзной заплаткой) почему-то отсуствуют.
Подробней о дыре http://xforce.iss.net/xforce/xfdb/72911 (5.3.8 уязвима не меньше 5.3.9).

Каков вообще цикл обновляемости младших версий, и с чем связаны такого рода задержки? - младшие версии не изменяют функциональности скриптов, но исправляют ошибки, иногда очень критичные.

Пожалуйста, не пишите о ручной установке / из портов. Вопрос вполне конкретный: о политике обновления общих пакетов.
driveparty
 
Сообщений: 7
Зарегистрирован: Пт фев 10, 2012 8:17 pm

Re: "шаблонный" PHP5 без обновлений уже пол-года!

Сообщение ls » Сб фев 18, 2012 4:28 pm

На версию 5.2.17 ставятся патчи исправлений http://code.google.com/p/php52-backports/ и они присутствуют в самом порте (версия порта php52-5.2.17_7)
Обновляться версия 5.2.17 до 5.3 в шаблоне FreeBSD-8-ISPmanager не будет. P.S. разработчиками шаблона являются ISPsystem, а не FirstVDS
* FirstVDS в twitter в facebook и в вконтакте *
ls
Support team
 
Сообщений: 6405
Зарегистрирован: Чт мар 01, 2007 10:36 am
Откуда: FirstVDS

Re: "шаблонный" PHP5 без обновлений уже пол-года!

Сообщение driveparty » Сб фев 18, 2012 8:52 pm

ls писал(а):На версию 5.2.17 ставятся патчи исправлений http://code.google.com/p/php52-backports/ и они присутствуют в самом порте (версия порта php52-5.2.17_7)
Обновляться версия 5.2.17 до 5.3 в шаблоне FreeBSD-8-ISPmanager не будет. P.S. разработчиками шаблона являются ISPsystem, а не FirstVDS


Простите, а вы вообще читали вопрос, или отвечали по заголовку? У меня хоть в одной строке про 5.2 было?! Я писал про 5-3(!)-10.

Что касается шаблонов – возможно я не совсем корректно выразился, но я имел ввиду общие для всех виртуальных машин пакеты, доступные всем пользователям. У меня (а из портов я PHP не ставил) сейчас работает версия 5.3.8. Максимум, что я мог ставить - это "обновление с php 5.2 до 5.3", или даже просто в "возможностях" удалял PHP и ставил уже 5.3.
Уж не знаю, как оно было реализовано, но, насколько я понимаю, речь должна была идти об общем для всей платформы ПО...? Или таким образом ставится что-то из портов?
driveparty
 
Сообщений: 7
Зарегистрирован: Пт фев 10, 2012 8:17 pm

Re: "шаблонный" PHP5 без обновлений уже пол-года!

Сообщение ls » Вс фев 19, 2012 5:25 am

Если вы установили какое либо ПО вручную (а с PHP в данном случае так - вы обновили PHP 5.2 до 5.3), то обновляться оно на сервере не будет автоматически.
В портах на VDS 5.3.10 присутствует. Обновляйте поставленный вручную PHP 5.3.8 до это версии штатными средствами операционной системы.
* FirstVDS в twitter в facebook и в вконтакте *
ls
Support team
 
Сообщений: 6405
Зарегистрирован: Чт мар 01, 2007 10:36 am
Откуда: FirstVDS

Re: "шаблонный" PHP5 без обновлений уже пол-года!

Сообщение driveparty » Вс фев 19, 2012 1:22 pm

ls писал(а):Если вы установили какое либо ПО вручную (а с PHP в данном случае так - вы обновили PHP 5.2 до 5.3), то обновляться оно на сервере не будет автоматически.
В портах на VDS 5.3.10 присутствует. Обновляйте поставленный вручную PHP 5.3.8 до это версии штатными средствами операционной системы.


Охххх..... вы бы пояснили что ли, что по-вашему значит "вручную"? По-моему, в контексте unix-систем под управлением всякого рода "панелей", это означает работу из shell, чего я не делал в отношение PHP совершенно определённо.
Из "возможностей" я удалил PHP 5.2.x, и установил заново PHP, выбрав 5.3.x, который тогда был доступен. Вчера я снова это проделал, и увидел, что доступен уже 5.3.10 (установил его). Не помешало бы, кстати, чтобы машинка запомнила extensions, и переустановила бы их обратно после такого апгрейда...
Это "вручную"? И, соот-но, это интерфейс к установке из портов? (в консоли видел отрабатывались fetch, pckgctrl, make и прочие)
Если так, то пычально, шо не все порты так устанавливаются, а также что нет маркировки "шаблонных" вариантов (ну хоть *звёздочки* бы поставили в списках выбора версий - это ж не аццкий труд :) ).

Вообще, не помешало бы поработать над пояснялкой: шо есть "шаблоны" и каков их текущий состав (в предпродажных разделах общие фразы "пакет php, сервер апач" и тп.), что именно происходит при том или ином изменении, и тд-тп. К вам же меньше вопросов было бы :) Я, например, полагал, что всё, шо доступно из панели входит в состав того или иного шаблона, и ставится shared, а всё, что я делаю из shell навроде установки портов или пакетов, или ручной сборки – это уже "мимо кассы".
driveparty
 
Сообщений: 7
Зарегистрирован: Пт фев 10, 2012 8:17 pm

Re: "шаблонный" PHP5 без обновлений уже пол-года!

Сообщение ls » Вс фев 19, 2012 5:20 pm

Обновляется автоматически только то программное обеспечение, которое предустановлено в шаблоне FreeBSD-8-ISPmanager. Если ставите какое-либо ПО дополнительно (другой версии), то оно перестает быть "шаблонным" и соответственно не обновляется.
* FirstVDS в twitter в facebook и в вконтакте *
ls
Support team
 
Сообщений: 6405
Зарегистрирован: Чт мар 01, 2007 10:36 am
Откуда: FirstVDS


Вернуться в CGI, Perl, PHP

Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 2