Установка Битрикса. Проблема с mbstring

Все о скриптах

Модераторы: Art.i, vasya

Установка Битрикса. Проблема с mbstring

Сообщение id » Пт июл 08, 2011 10:02 am

Для корректной установки битрикса необходимо выставить значения.
Код: выделить все
mbstring.func_overload = 2
mbstring.internal_encoding = UTF-8

Я сделал это в php.ini, также пробовал в .htaccess, но это не помогает. Где нужно изменить эти значения, чтобы они заработали?
id
 
Сообщений: 9
Зарегистрирован: Чт июл 30, 2009 10:23 pm

Re: Установка Битрикса. Проблема с mbstring

Сообщение ls » Пт июл 08, 2011 2:03 pm

В php.ini и нужно писать? Какая ОС, какой режим работы PHP? После внесения правок в php.ini надо перезапускать apache, о том что реально были изменения увидеть можно через phpinfo();
* FirstVDS в twitter в facebook и в вконтакте *
ls
Support team
 
Сообщений: 6389
Зарегистрирован: Чт мар 01, 2007 10:36 am
Откуда: FirstVDS

Re: Установка Битрикса. Проблема с mbstring

Сообщение id » Пт июл 08, 2011 2:07 pm

Проблему я решил.
Оказалось, что изменения действуют только для файла /home/user/data/php-bin/php.ini
Для меня это оказалось небольшим открытием.
id
 
Сообщений: 9
Зарегистрирован: Чт июл 30, 2009 10:23 pm

Re: Установка Битрикса. Проблема с mbstring

Сообщение valerij1257 » Ср дек 24, 2014 12:01 pm

Добрый день,
А не расскажете как сделали?
valerij1257
 
Сообщений: 1
Зарегистрирован: Ср дек 24, 2014 11:53 am

Re: Установка Битрикса. Проблема с mbstring

Сообщение Art.i » Сб фев 27, 2016 1:36 am

Судя по его описанию включил для домена режим работы PHP как CGI и внёс соответствующие значения в файл /home/user/data/php-bin/php.ini
Art.i
Support team
 
Сообщений: 719
Зарегистрирован: Ср сен 25, 2013 2:07 pm


Вернуться в CGI, Perl, PHP

Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 5