Нужно откатить php 5.4 до 5.2.

Все о скриптах

Модераторы: Art.i, vasya

Нужно откатить php 5.4 до 5.2.

Сообщение maks97nnnn » Вс фев 22, 2015 11:36 am

Здравствуйте!

Имеется kmv сервер, на всех сборках дебиан именно 5.3 и 5.4.
Как можно откатить версию назад?
maks97nnnn
 
Сообщений: 27
Зарегистрирован: Вс дек 07, 2014 6:26 pm

Re: Нужно откатить php 5.4 до 5.2.

Сообщение pepper » Вс фев 22, 2015 11:47 am

Можете использовать php-brew:
http://habrahabr.ru/post/210764/

Или собрать из исходников нужную версию РНР в отдельной директории так:
http://sabini.ch/articles/ustanovka-php ... tos-6.html
pepper
Support team
 
Сообщений: 551
Зарегистрирован: Пн окт 07, 2013 4:06 am

Re: Нужно откатить php 5.4 до 5.2.

Сообщение maks97nnnn » Вс фев 22, 2015 12:05 pm

Так у меня же дебиан, а не центос, или там одинаково?
И как удалить обновленную версию?
maks97nnnn
 
Сообщений: 27
Зарегистрирован: Вс дек 07, 2014 6:26 pm

Re: Нужно откатить php 5.4 до 5.2.

Сообщение pepper » Вс фев 22, 2015 12:15 pm

Я привел для примера, пакеты для установки называются почти так же, просто используйте другой менеджер пакетов (apt-get вместо yum).
Оба варианта предназначены для установки параллельно с текущей версией РНР в системе.
pepper
Support team
 
Сообщений: 551
Зарегистрирован: Пн окт 07, 2013 4:06 am

Re: Нужно откатить php 5.4 до 5.2.

Сообщение maks97nnnn » Вс фев 22, 2015 1:52 pm

Чтобы все было праивльно попробовал перенести не центос, все также как на дебион, кроме пункта 5. Приступить к сборке

Там весь код сразу можно вводить или отдельно нужно?
Я сначала первую строчку пробую, а потом функции с ./configure, но отвечает "No such file or directory". make install тоже не работаем, можно этот пункт по ходам разбить?
maks97nnnn
 
Сообщений: 27
Зарегистрирован: Вс дек 07, 2014 6:26 pm

Re: Нужно откатить php 5.4 до 5.2.

Сообщение pepper » Вс фев 22, 2015 2:18 pm

Можно сразу, а можно по строкам.
Если отвечает "No such file or directory", значит в вашей директории нет configure, хотя такой файл должен присутствовать.
Предыдущий пункт выполните так (по ссылке не хватает пробела и точки с запятой, похоже):
wget http://museum.php.net/php5/php-5.2.17.tar.gz
tar -xzf php-5.2.17.tar.gz -C /tmp

после этого в /tmp ./configure должен сработать.
pepper
Support team
 
Сообщений: 551
Зарегистрирован: Пн окт 07, 2013 4:06 am

Re: Нужно откатить php 5.4 до 5.2.

Сообщение maks97nnnn » Вс фев 22, 2015 2:32 pm

Сравнил обе строки, вроде идентичны.

Ставится, но потом вылазит пост:
-bash: ./configure: No such file or directory
[root@сервер tmp]# make
make: *** No targets specified and no makefile found. Stop.
maks97nnnn
 
Сообщений: 27
Зарегистрирован: Вс дек 07, 2014 6:26 pm

Re: Нужно откатить php 5.4 до 5.2.

Сообщение pepper » Вс фев 22, 2015 2:45 pm

>> Сравнил обе строки, вроде идентичны.
По ссылке в третьем пункте не хватает переноса строки.

Попробуйте третий пункт выполнить так:
Код: выделить все
wget http://museum.php.net/php5/php-5.2.17.tar.gz
mkdir /tmp/php52
tar -xzf php-5.2.17.tar.gz -C /tmp/php52
cd /tmp/php52

После попробуйте выполнить строку, начинающуюся с ./configure
pepper
Support team
 
Сообщений: 551
Зарегистрирован: Пн окт 07, 2013 4:06 am

Re: Нужно откатить php 5.4 до 5.2.

Сообщение maks97nnnn » Вс фев 22, 2015 2:47 pm

-bash: cd: /tmp/php52./configure: No such file or directory
[root@linkwmr tmp]# make
make: *** No targets specified and no makefile found. Stop.
[root@linkwmr tmp]# make install


Это если после кионфигуры до мейка.

-bash: ./configure: No such file or directory

А это если только функции.
maks97nnnn
 
Сообщений: 27
Зарегистрирован: Вс дек 07, 2014 6:26 pm

Re: Нужно откатить php 5.4 до 5.2.

Сообщение pepper » Вс фев 22, 2015 3:19 pm

Не нужно выполнять такую команду:
Код: выделить все
cd /tmp/php52./configure

нужно выполнять две таких:
Код: выделить все
cd /tmp/php52
./configure


Если всё равно не получится ,приведите, пожалуйста, полный вывод всех результатов выполнения инструкции.
Большие куски текста/кода можно вставлять на http://pastebin.com/ и потом постить тут только ссылку.
pepper
Support team
 
Сообщений: 551
Зарегистрирован: Пн окт 07, 2013 4:06 am

Re: Нужно откатить php 5.4 до 5.2.

Сообщение maks97nnnn » Вс фев 22, 2015 3:30 pm

Опять не получилось
http://pastebin.com/RvjZxmhw
maks97nnnn
 
Сообщений: 27
Зарегистрирован: Вс дек 07, 2014 6:26 pm

Re: Нужно откатить php 5.4 до 5.2.

Сообщение pepper » Вс фев 22, 2015 3:41 pm

Покажите листинг директории /tmp/php52 так:
Код: выделить все
ls -ahl /tmp/php52
pepper
Support team
 
Сообщений: 551
Зарегистрирован: Пн окт 07, 2013 4:06 am

Re: Нужно откатить php 5.4 до 5.2.

Сообщение maks97nnnn » Вс фев 22, 2015 3:53 pm

Так имеете ввиду?
maks97nnnn
 
Сообщений: 27
Зарегистрирован: Вс дек 07, 2014 6:26 pm

Re: Нужно откатить php 5.4 до 5.2.

Сообщение pepper » Вс фев 22, 2015 3:59 pm

Доступ по ссылке запрещен - 403, в Pastebin.com вставьте вывод.
pepper
Support team
 
Сообщений: 551
Зарегистрирован: Пн окт 07, 2013 4:06 am

Re: Нужно откатить php 5.4 до 5.2.

Сообщение maks97nnnn » Вс фев 22, 2015 4:08 pm

Странно, вот на пасте
http://pastebin.com/HkkHJUv1
maks97nnnn
 
Сообщений: 27
Зарегистрирован: Вс дек 07, 2014 6:26 pm

След.

Вернуться в CGI, Perl, PHP

Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 4