Обновление php 5.3.3 до последней в этой ветке

Все о скриптах

Модераторы: Art.i, vasya

Обновление php 5.3.3 до последней в этой ветке

Сообщение segajb » Ср окт 08, 2014 8:24 am

Стоит centos, ispmanager 5
Как обновить php c версии 5.3 только не до 5.4 а до последней в ветке 5.3 или хотя бы до 5.3.10 или позднее?
segajb
 
Сообщений: 48
Зарегистрирован: Чт июн 21, 2012 6:18 pm

Re: Обновление php 5.3.3 до последней в этой ветке

Сообщение ls » Ср окт 08, 2014 8:54 am

Поставьте отсюда http://centosup.ispsystem.info/
Код: выделить все
wget -O /etc/yum.repos.d/centosup.repo http://centosup.ispsystem.info/centosup.repo
yum makecache


Код: выделить все
yum update php-\*
* FirstVDS в twitter в facebook и в вконтакте *
ls
Support team
 
Сообщений: 6389
Зарегистрирован: Чт мар 01, 2007 10:36 am
Откуда: FirstVDS

Re: Обновление php 5.3.3 до последней в этой ветке

Сообщение MighelRuis » Вт сен 01, 2015 4:00 pm

При попытке обновить PHP появляется ошибка:
Код: выделить все
[root@mighelruis ~]# yum update php
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
Could not get metalink https://mirrors.fedoraproject.org/metalink?repo=epel-6&ar             ch=i386 error was
14: problem making ssl connection
 * atomic: mirror1.34sp.com
 * base: centos-mirror.rbc.ru
 * epel: fedora-mirror01.rbc.ru
 * extras: centos-mirror.rbc.ru
 * updates: centos-mirror.rbc.ru
http://centosup.ispsystem.info/repo/i386/repodata/repomd.xml: [Errno 14] PYCURL              ERROR 22 - "The requested URL returned error: 404"
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: centosup             . Please verify its path and try again


Помогите решить проблему.
CentOS 6.3, php 5.3.3
MighelRuis
 
Сообщений: 6
Зарегистрирован: Вт сен 01, 2015 3:55 pm

Re: Обновление php 5.3.3 до последней в этой ветке

Сообщение ls » Вт сен 01, 2015 4:05 pm

Для 32 битной ОС нет пакетов в данном репозитории
* FirstVDS в twitter в facebook и в вконтакте *
ls
Support team
 
Сообщений: 6389
Зарегистрирован: Чт мар 01, 2007 10:36 am
Откуда: FirstVDS

Re: Обновление php 5.3.3 до последней в этой ветке

Сообщение MighelRuis » Вт сен 01, 2015 4:09 pm

ls писал(а):Для 32 битной ОС нет пакетов в данном репозитории
И что делать? Как быть?
MighelRuis
 
Сообщений: 6
Зарегистрирован: Вт сен 01, 2015 3:55 pm

Re: Обновление php 5.3.3 до последней в этой ветке

Сообщение MighelRuis » Вт сен 01, 2015 4:50 pm

Попробовал обновить из Atomic, по инструкции (http://firstwiki.ru/index.php/Переустановка_PHP_с_любой_версии_на_любую,_FreeBSD#PHP_5.3_.3E.3E_PHP_5.4). Результат:

Код: выделить все
[root@mighelruis ~]# yum update php
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
Could not get metalink https://mirrors.fedoraproject.org/metalink?repo=epel-6&arch=i386 error was
14: problem making ssl connection
 * atomic: www5.atomicorp.com
 * base: centos-mirror.rbc.ru
 * epel: fedora-mirror01.rbc.ru
 * extras: centos-mirror.rbc.ru
 * updates: centos-mirror.rbc.ru
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package php.i686 0:5.3.3-14.el6_3 will be updated
--> Processing Dependency: php = 5.3.3-14.el6_3 for package: php-devel-5.3.3-14.el6_3.i686
---> Package php.i686 0:5.4.44-50.el6.art will be an update
--> Processing Dependency: php-common(x86-32) = 5.4.44-50.el6.art for package: php-5.4.44-50.el6.art.i686
--> Processing Dependency: php-cli(x86-32) = 5.4.44-50.el6.art for package: php-5.4.44-50.el6.art.i686
--> Processing Dependency: libssl.so.10(libssl.so.10) for package: php-5.4.44-50.el6.art.i686
--> Processing Dependency: libcrypto.so.10(libcrypto.so.10) for package: php-5.4.44-50.el6.art.i686
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.1_EC) for package: php-5.4.44-50.el6.art.i686
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.1) for package: php-5.4.44-50.el6.art.i686
--> Running transaction check
---> Package openssl.i686 0:1.0.0-25.el6_3.1 will be updated
---> Package openssl.i686 0:1.0.1e-42.el6 will be an update
---> Package php-cli.i686 0:5.3.3-14.el6_3 will be updated
---> Package php-cli.i686 0:5.4.44-50.el6.art will be an update
---> Package php-common.i686 0:5.3.3-14.el6_3 will be updated
--> Processing Dependency: php(api) = 20090626 for package: php-pecl-imagick-2.2.2-4.el6.i686
--> Processing Dependency: php(zend-abi) = 20090626 for package: php-pecl-imagick-2.2.2-4.el6.i686
--> Processing Dependency: php-api = 20090626 for package: php-mcrypt-5.3.3-1.el6.i686
--> Processing Dependency: php-common = 5.3.3-14.el6_3 for package: php-pdo-5.3.3-14.el6_3.i686
--> Processing Dependency: php-common = 5.3.3-14.el6_3 for package: php-mbstring-5.3.3-14.el6_3.i686
--> Processing Dependency: php-common = 5.3.3-14.el6_3 for package: php-gd-5.3.3-14.el6_3.i686
--> Processing Dependency: php-common = 5.3.3-14.el6_3 for package: php-mysql-5.3.3-14.el6_3.i686
--> Processing Dependency: php-common = 5.3.3-14.el6_3 for package: php-xml-5.3.3-14.el6_3.i686
---> Package php-common.i686 0:5.4.44-50.el6.art will be an update
---> Package php-devel.i686 0:5.3.3-14.el6_3 will be updated
---> Package php-devel.i686 0:5.4.44-50.el6.art will be an update
--> Running transaction check
---> Package php-common.i686 0:5.3.3-14.el6_3 will be updated
--> Processing Dependency: php(api) = 20090626 for package: php-pecl-imagick-2.2.2-4.el6.i686
--> Processing Dependency: php(zend-abi) = 20090626 for package: php-pecl-imagick-2.2.2-4.el6.i686
---> Package php-gd.i686 0:5.3.3-14.el6_3 will be updated
---> Package php-gd.i686 0:5.4.44-50.el6.art will be an update
--> Processing Dependency: libt1.so.5 for package: php-gd-5.4.44-50.el6.art.i686
--> Processing Dependency: libjpeg.so.62(LIBJPEG_6.2) for package: php-gd-5.4.44-50.el6.art.i686
---> Package php-mbstring.i686 0:5.3.3-14.el6_3 will be updated
---> Package php-mbstring.i686 0:5.4.44-50.el6.art will be an update
---> Package php-mcrypt.i686 0:5.3.3-1.el6 will be updated
---> Package php-mcrypt.i686 0:5.4.44-50.el6.art will be an update
---> Package php-mysql.i686 0:5.3.3-14.el6_3 will be updated
---> Package php-mysql.i686 0:5.4.44-50.el6.art will be an update
---> Package php-pdo.i686 0:5.3.3-14.el6_3 will be updated
---> Package php-pdo.i686 0:5.4.44-50.el6.art will be an update
---> Package php-xml.i686 0:5.3.3-14.el6_3 will be updated
---> Package php-xml.i686 0:5.4.44-50.el6.art will be an update
--> Running transaction check
---> Package libjpeg.i686 0:6b-46.el6 will be obsoleted
---> Package libjpeg-turbo.i686 0:1.2.1-3.el6_5 will be obsoleting
---> Package php-common.i686 0:5.3.3-14.el6_3 will be updated
--> Processing Dependency: php(api) = 20090626 for package: php-pecl-imagick-2.2.2-4.el6.i686
--> Processing Dependency: php(zend-abi) = 20090626 for package: php-pecl-imagick-2.2.2-4.el6.i686
---> Package t1lib.i686 0:5.1.2-6.el6_2.1 will be installed
--> Finished Dependency Resolution
Error: Package: php-pecl-imagick-2.2.2-4.el6.i686 (@epel)
           Requires: php(api) = 20090626
           Removing: php-common-5.3.3-14.el6_3.i686 (@updates)
               php(api) = 20090626
           Updated By: php-common-5.4.44-50.el6.art.i686 (atomic)
               php(api) = 20100412-x86-32
           Available: atomic-php55-php-common-5.5.27-27.el6.art.i686 (atomic)
               php(api) = 20121113-32
           Available: atomic-php55-php-common-5.5.28-28.el6.art.i686 (atomic)
               php(api) = 20121113-32
           Available: atomic-php56-php-common-5.6.11-26.el6.art.i686 (atomic)
               php(api) = 20131106-32
           Available: atomic-php56-php-common-5.6.12-28.el6.art.i686 (atomic)
               php(api) = 20131106-32
           Available: php-common-5.3.3-40.el6_6.i686 (base)
               php(api) = 20090626
           Available: php-common-5.3.3-46.el6_6.i686 (updates)
               php(api) = 20090626
           Available: php-common-5.4.42-48.el6.art.i686 (atomic)
               php(api) = 20100412-x86-32
           Available: php-common-5.4.43-49.el6.art.i686 (atomic)
               php(api) = 20100412-x86-32
Error: Package: php-pecl-imagick-2.2.2-4.el6.i686 (@epel)
           Requires: php(zend-abi) = 20090626
           Removing: php-common-5.3.3-14.el6_3.i686 (@updates)
               php(zend-abi) = 20090626
           Updated By: php-common-5.4.44-50.el6.art.i686 (atomic)
               php(zend-abi) = 20100525-x86-32
           Available: atomic-php55-php-common-5.5.27-27.el6.art.i686 (atomic)
               php(zend-abi) = 20121212-32
           Available: atomic-php55-php-common-5.5.28-28.el6.art.i686 (atomic)
               php(zend-abi) = 20121212-32
           Available: atomic-php56-php-common-5.6.11-26.el6.art.i686 (atomic)
               php(zend-abi) = 20131226-32
           Available: atomic-php56-php-common-5.6.12-28.el6.art.i686 (atomic)
               php(zend-abi) = 20131226-32
           Available: php-common-5.3.3-40.el6_6.i686 (base)
               php(zend-abi) = 20090626
           Available: php-common-5.3.3-46.el6_6.i686 (updates)
               php(zend-abi) = 20090626
           Available: php-common-5.4.42-48.el6.art.i686 (atomic)
               php(zend-abi) = 20100525-x86-32
           Available: php-common-5.4.43-49.el6.art.i686 (atomic)
               php(zend-abi) = 20100525-x86-32
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
MighelRuis
 
Сообщений: 6
Зарегистрирован: Вт сен 01, 2015 3:55 pm

Re: Обновление php 5.3.3 до последней в этой ветке

Сообщение MighelRuis » Вт сен 01, 2015 5:04 pm

Проблема решена. Atomic удалил и обновил php по инструкции https://itldc.com/blog/php54-upgrade-centos6x/
MighelRuis
 
Сообщений: 6
Зарегистрирован: Вт сен 01, 2015 3:55 pm


Вернуться в CGI, Perl, PHP

Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1