Сервер входящей почты

pop, smtp, sendmail etc

Модераторы: Art.i, vasya

Сервер входящей почты

Сообщение sorg » Ср сен 28, 2005 9:28 am

сабж не работает :) не пойму почему, может подскажите?
на отправку все ОК
sorg
 
Сообщений: 62
Зарегистрирован: Вт янв 18, 2005 5:22 pm

Re: Сервер входящей почты

Сообщение Maks » Ср сен 28, 2005 10:20 am

sorg писал(а):сабж не работает :) не пойму почему, может подскажите? на отправку все ОК


Более широко развернуть вопрос можешь? Что именно у тебя не работает то?
Maks
Advanced customer
 
Сообщений: 146
Зарегистрирован: Вс авг 21, 2005 8:01 pm
Откуда: Днепропетровск

Сообщение sorg » Ср сен 28, 2005 10:30 am

не работает именно прием почты по pop3 протоколу. Через WebMail все ок, через БАТ нифика, видимо были обновления на серверах и чтото гдето изменилось. Настройки БАТа в норме.
sorg
 
Сообщений: 62
Зарегистрирован: Вт янв 18, 2005 5:22 pm

Сообщение Maks » Ср сен 28, 2005 10:35 am

"Не работает" - понятие растяжимое.
Какими ошибками ругается Бат, что в логах? Диагностика проблемы не видна...
Maks
Advanced customer
 
Сообщений: 146
Зарегистрирован: Вс авг 21, 2005 8:01 pm
Откуда: Днепропетровск

Сообщение sorg » Ср сен 28, 2005 10:37 am

ругается на невозможность соединения с сервером
sorg
 
Сообщений: 62
Зарегистрирован: Вт янв 18, 2005 5:22 pm

Сообщение Maks » Ср сен 28, 2005 10:40 am

Телнетом пробовал подключиться к нему?
telnet you_server.ru 110
Что говорит?

Кроме того, что у тебя в ipfw с правилами для 110-го порта?
Maks
Advanced customer
 
Сообщений: 146
Зарегистрирован: Вс авг 21, 2005 8:01 pm
Откуда: Днепропетровск

Сообщение sorg » Ср сен 28, 2005 10:44 am

C:\Documents and Settings\admin>telnet my_site 110
Подключение к my_site...
Не удалось открыть подключение к этому узлу, на порт 110: Сбой подключения
>>Кроме того, что у тебя в ipfw с правилами для 110-го порта?
пардон, а это что?
Хочу сказать, что вчера вечером все работало, сегодня с утра проМблемы :)
sorg
 
Сообщений: 62
Зарегистрирован: Вт янв 18, 2005 5:22 pm

Сообщение Maks » Ср сен 28, 2005 10:53 am

sorg писал(а):
Maks писал(а):Кроме того, что у тебя в ipfw с правилами для 110-го порта?

пардон, а это что? Хочу сказать, что вчера вечером все работало, сегодня с утра проМблемы :)


Вообще ipfw - это фаерволл FreeBSD, и если ты его ковырял, то явно мог указать запрещать доступ к 110 порту. На эту тему рыть /etc/rc.firewall
Это первое. Второе - не факт что проблемы у тебя именно с сервером, поскольку это может быть глючок в винде за которой ты сидишь. Если есть желание скажи адрес своего сервера - попробую приконнектиться, или сам попробуй со своего же шелла:

telnet localhost 110
telnet you_domain.ru 110

Если первое будет удачно, а второе нет - то скорее всего кривые правила доступа (возможно в ipfw). Если будут успешны оба, то либо ты что то набокопорил у себя в винде, либо ты закрыл свою же винде от подключения куда либо на 110 порт, либо это мог сделать твой провайдер.

Нужно копать.
Maks
Advanced customer
 
Сообщений: 146
Зарегистрирован: Вс авг 21, 2005 8:01 pm
Откуда: Днепропетровск

Сообщение sorg » Ср сен 28, 2005 11:04 am

telnet localhost 110
telnet you_domain.ru 110

ни первое, ни виторое не удачно :(
Вообще ipfw - это фаерволл FreeBSD, и если ты его ковырял, то явно мог указать запрещать доступ к 110 порту.

не ковырял :D честно пионерское ;)
На эту тему рыть /etc/rc.firewall

открыл, порыл, подстроки 110 в файле нет
то либо ты что то набокопорил у себя в винде, либо ты закрыл свою же винде от подключения куда либо на 110 порт, либо это мог сделать твой провайдер.

C:\Documents and Settings\admin>telnet firstvds.ru 110
Подключение к firstvds.ru...
+OK Qpopper (version 4.0.5) at firstvds.ru starting. <44361.1127894474@firstvds
.ru>
sorg
 
Сообщений: 62
Зарегистрирован: Вт янв 18, 2005 5:22 pm

Сообщение Maks » Ср сен 28, 2005 11:13 am

sorg писал(а):telnet localhost 110
telnet you_domain.ru 110
ни первое, ни второе не удачно :(


Ты это пробовал с шелла сделать?
Вообще мог либо демон умереть, либо какая то другая темная сила мешает нормальным людям... ;)
Поищи, соответсвующий процесс висит ли в top'е?
Maks
Advanced customer
 
Сообщений: 146
Зарегистрирован: Вс авг 21, 2005 8:01 pm
Откуда: Днепропетровск

Сообщение sorg » Ср сен 28, 2005 11:15 am

да, это с шелла
после ребута сервака по идее демон должОн был запуститься, но... я не знаю.
USER PID %CPU %MEM VSZ RSS TT STAT STARTED TIME COMMAND
root 46762 1.1 0.2 5300 2032 ?? SsJ 12:14PM 0:00.36 sshd: root@ttyp2 (
root 47300 0.0 0.1 2740 1496 p2 SsJ 12:15PM 0:00.03 -bash (bash)
root 36355 0.0 0.9 11640 9060 ?? IJ 11:23AM 0:14.57 /usr/local/ispmgr/
www 24504 0.0 1.2 19564 12580 ?? IJ 10:25AM 0:06.17 /usr/local/sbin/ht
www 24502 0.0 0.9 16532 9468 ?? IJ 10:25AM 0:04.50 /usr/local/sbin/ht
mysql 24500 0.0 0.4 6688 3888 ?? SJ 10:25AM 0:03.72 /usr/local/libexec
www 24468 0.0 1.2 19456 12476 ?? IJ 10:25AM 0:04.48 /usr/local/sbin/ht
mysql 24465 0.0 0.0 652 284 ?? IJ 10:25AM 0:00.02 /bin/sh /usr/local
root 24433 0.0 0.5 12844 5640 ?? SsJ 10:25AM 0:00.62 /usr/local/sbin/ht
root 24432 0.0 0.1 1380 840 ?? IsJ 10:25AM 0:00.58 /usr/local/ispmgr/
root 24391 0.0 0.3 3884 3000 ?? SsJ 10:25AM 0:00.51 sendmail: acceptin
root 24388 0.0 0.1 1060 720 ?? SsJ 10:25AM 0:00.07 /usr/sbin/cron
root 24386 0.0 0.1 1088 752 ?? SsJ 10:25AM 0:00.01 /usr/sbin/inetd -w
root 24380 0.0 0.3 4660 3080 ?? SsJ 10:25AM 0:00.27 /usr/sbin/named
root 47329 0.0 0.0 408 212 p2 R+J 12:15PM 0:00.00 ps -aux
root 24377 0.0 0.1 996 612 ?? SsJ 10:25AM 0:00.08 /usr/sbin/syslogd
sorg
 
Сообщений: 62
Зарегистрирован: Вт янв 18, 2005 5:22 pm

Сообщение Евграф » Ср сен 28, 2005 11:16 am

Если вы используете dovecot, то проблема может быть связана с обновлением сего зверя, у которого несколько изменился файл конфигурации. Проблема может возникнуть у тех клиентов, кто лазил в конфиг руками, то есть у тех, у кого он свой, а не темплейтный
Восстановление темплейтного конфига должно помочь

cd /usr/local/etc
mv dovecot.conf dovecot.conf.my
rm -W dovecot.conf
rc.d/dovecot.sh stop
rc.d/dovecot.sh start
Евграф
Support team
 
Сообщений: 94
Зарегистрирован: Чт янв 09, 2003 1:14 pm

Сообщение Maks » Ср сен 28, 2005 11:27 am

sorg писал(а):Через WebMail все ок, через БАТ нифика


Просто потому что webmail использует imap доступ.
Maks
Advanced customer
 
Сообщений: 146
Зарегистрирован: Вс авг 21, 2005 8:01 pm
Откуда: Днепропетровск

Сообщение sorg » Ср сен 28, 2005 12:02 pm

в конфиг руками не лазил, это новый вдс и там еще ничего не делал.
Сейчас попробую и отпишусь
cd /usr/local/etc
mv dovecot.conf dovecot.conf.my
rm -W dovecot.conf
rc.d/dovecot.sh stop
rc.d/dovecot.sh start
sorg
 
Сообщений: 62
Зарегистрирован: Вт янв 18, 2005 5:22 pm

Сообщение sorg » Ср сен 28, 2005 12:06 pm

root# rc.d/dovecot.sh start
Starting dovecot.
Warning: Ignoring deprecated 'login' section handling. Use protocol imap/pop3 { .. } instead. Some settings may have been read incorrectly.
Warning: Ignoring deprecated 'login' section handling. Use protocol imap/pop3 { .. } instead. Some settings may have been read incorrectly.
Error: Error in configuration file /usr/local/etc/dovecot.conf line 245: Unknown setting: client_workarounds
root#
sorg
 
Сообщений: 62
Зарегистрирован: Вт янв 18, 2005 5:22 pm

След.

Вернуться в Вопросы о e-mail

Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 2