Установка sbnc.

Все вопросы связанные с IRC

Модераторы: Art.i, vasya

Установка sbnc.

Сообщение triton996 » Ср июл 03, 2013 7:20 pm

triton999@triton999:~$ cd sbnc-1.3rus
triton999@triton999:~/sbnc-1.3rus$ ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking for sed... /bin/sed
checking whether make sets $(MAKE)... (cached) yes
checking for g++... no
checking for c++... no
checking for gpp... no
checking for aCC... no
checking for CC... no
checking for cxx... no
checking for cc++... no
checking for cl.exe... no
checking for FCC... no
checking for KCC... no
checking for RCC... no
checking for xlC_r... no
checking for xlC... no
checking whether the C++ compiler works... no
configure: error: in `/var/www/triton999/data/sbnc-1.3rus':
configure: error: C++ compiler cannot create executables

See `config.log' for more details
triton999@triton999:~/sbnc-1.3rus$ gmake
-bash: gmake: command not found
triton999@triton999:~/sbnc-1.3rus$ make
make: *** No targets specified and no makefile found. Stop.

Установленно g++, с++, gpp, make (через рут) . ОС Debian. Куда копать?
triton996
 
Сообщений: 27
Зарегистрирован: Вт июн 29, 2010 3:09 pm

Re: Установка sbnc.

Сообщение triton996 » Ср июл 03, 2013 7:23 pm

при установки C++
Код: выделить все
                          Conflicts: python-carquinyol
 python-cherrypy3 : Conflicts: python-cherrypy but 2.3.0-3 is to be installed
                    Conflicts: python2.4-cherrypy
 python-petsc4py : Depends: libhdf5-openmpi-1.8.4 but it is not going to be inst                                                                             alled
 qpopper-drac : Conflicts: pop3-server
 quassel-client : Depends: quassel-data (= 0.6.3-2+squeeze2) but it is not going                                                                              to be installed
                  Conflicts: quassel-client-kde4 but 0.6.3-2+squeeze2 is to be i                                                                             nstalled
 quassel-client-kde4 : Conflicts: quassel-client but 0.6.3-2+squeeze2 is to be i                                                                             nstalled
 r-cran-rjava : Depends: openjdk-6-jre but it is not going to be installed
 radioclk : Depends: ntp (>= 1:4.2.2+dfsg-1) but it is not going to be installed
 radiusclient1 : Conflicts: libradiusclient-ng-dev but 0.5.6-1.1 is to be instal                                                                             led
 ratbox-services-mysql : Conflicts: ratbox-services
 ratbox-services-pgsql : Conflicts: ratbox-services
 ratbox-services-sqlite : Conflicts: ratbox-services
 rcconf : Conflicts: file-rc but 0.8.12 is to be installed
 remuco-mpd : Depends: mpd (>= 0.13.2) but it is not going to be installed
 rxvt-unicode-lite : Conflicts: rxvt-unicode
 rxvt-unicode-ml : Conflicts: rxvt-unicode
 scid-rating-data : Conflicts: scid-spell-data but 200901-2 is to be installed
 scid-spell-data : Conflicts: scid-rating-data but 200901-2 is to be installed
 scponly : Conflicts: scponly-full but 4.8-4.1 is to be installed
 scponly-full : Conflicts: scponly but 4.8-4.1 is to be installed
 skksearch : Conflicts: skkserv
 slony1-2-doc : Conflicts: slony1-doc
 stardict-gnome : Conflicts: stardict-gtk but 3.0.1-7 is to be installed
 stardict-gtk : Conflicts: stardict-gnome but 3.0.1-7 is to be installed
 sucrose-0.84 : Depends: network-manager but it is not going to be installed
                Conflicts: sugar
 sucrose-0.86 : Depends: sugar-session-0.86 but it is not going to be installed
                Depends: sugar-emulator-0.86 but it is not going to be installed
                Depends: sugar-tools-0.86 but it is not going to be installed
                Depends: network-manager but it is not going to be installed
                Conflicts: sugar
 sucrose-0.88 : Depends: sugar-session-0.88 but it is not going to be installed
                Depends: sugar-emulator-0.88 but it is not going to be installed
                Depends: sugar-tools-0.88 but it is not going to be installed
                Depends: network-manager but it is not going to be installed
                Conflicts: sugar
 sugar-browse-activity-0.84 : Recommends: sugar-0.84 but it is not installable
                              Conflicts: sugar-browse-activity
                              Conflicts: sugar-web-activity
 sugar-browse-activity-0.86 : Depends: python-sugar-0.86 but it is not going to                                                                              be installed or
                                       python-sugar-0.88 but it is not going to                                                                              be installed
                              Depends: python-sugar-toolkit-0.86 but it is not g                                                                             oing to be installed or
                                       python-sugar-toolkit-0.88 but it is not g                                                                             oing to be installed
                              Recommends: sugar-0.86 but it is not installable o                                                                             r
                                          sugar-0.88 but it is not installable
                              Recommends: sugar-artwork-0.86 but it is not going                                                                              to be installed or
                                          sugar-artwork-0.88 but it is not going                                                                              to be installed
                              Conflicts: sugar-browse-activity
                              Conflicts: sugar-web-activity
 sugar-chat-activity-0.84 : Recommends: sugar-0.84 but it is not installable
                            Conflicts: sugar-chat-activity
 sugar-chat-activity-0.86 : Depends: python-sugar-0.86 but it is not going to be                                                                              installed or
                                     python-sugar-0.88 but it is not going to be                                                                              installed
                            Depends: python-sugar-toolkit-0.86 but it is not goi                                                                             ng to be installed or
                                     python-sugar-toolkit-0.88 but it is not goi                                                                             ng to be installed
                            Recommends: sugar-0.86 but it is not installable or
                                        sugar-0.88 but it is not installable
                            Conflicts: sugar-chat-activity
 sugar-presence-service-0.84 : Recommends: sugar-0.84 but it is not installable
                               Recommends: network-manager (>= 0.7) but it is no                                                                             t going to be installed
                               Conflicts: sugar-presence-service
 sugar-presence-service-0.86 : Depends: python-sugar-toolkit-0.86 but it is not                                                                              going to be installed
                               Recommends: sugar-0.86 but it is not installable
                               Recommends: network-manager (>= 0.7) but it is no                                                                             t going to be installed
                               Conflicts: sugar-presence-service
 sugar-presence-service-0.88 : Depends: python-sugar-toolkit-0.88 but it is not                                                                              going to be installed
                               Recommends: sugar-0.88 but it is not installable
                               Recommends: network-manager (>= 0.7) but it is no                                                                             t going to be installed
                               Conflicts: sugar-presence-service
 sugar-read-activity-0.84 : Conflicts: sugar-read-activity
 sugar-read-activity-0.86 : Depends: python-sugar-toolkit-0.86 but it is not goi                                                                             ng to be installed or
                                     python-sugar-toolkit-0.88 but it is not goi                                                                             ng to be installed
                            Conflicts: sugar-read-activity
 synce-hal : Conflicts: synce-serial but 0.11-5.3 is to be installed
 sysv-rc : Conflicts: file-rc but 0.8.12 is to be installed
 tcl-trf-doc : Conflicts: libtrf-tcl
               Conflicts: libtrf-tcl-dev
 tcl8.4-doc : Conflicts: tcldoc
 tcl8.5-doc : Conflicts: tcl8.4-doc but 8.4.19-4 is to be installed
              Conflicts: tcldoc
 tk8.4-doc : Conflicts: tkdoc
 tk8.5-doc : Conflicts: tk8.4-doc but 8.4.19-4 is to be installed
             Conflicts: tkdoc
 torque-client : Conflicts: gridengine-client but 6.2u5-1squeeze1 is to be insta                                                                             lled
 torque-client-x11 : Conflicts: gridengine-client but 6.2u5-1squeeze1 is to be i                                                                             nstalled
                     Conflicts: torque-client
 torrus-apache2 : Conflicts: apache2-mpm-event but 2.2.16-6+squeeze11 is to be i                                                                             nstalled
                  Conflicts: apache2-mpm-worker but 2.2.16-6+squeeze11 is to be                                                                              installed
 ttf-ipafont-mincho : Conflicts: otf-ipafont-mincho but 00302-9 is to be install                                                                             ed
 ttf-kochi-gothic : Conflicts: ttf-kochi-gothic-naga10
 ttf-kochi-gothic-naga10 : Conflicts: ttf-kochi-gothic
 ttf-kochi-mincho : Conflicts: ttf-kochi-mincho-naga10
 ttf-kochi-mincho-naga10 : Conflicts: ttf-kochi-mincho
 ucspi-tcp-ipv6 : Conflicts: ucspi-tcp
 unixodbc-dev : Conflicts: libiodbc2-dev but 3.52.6-4 is to be installed
 unscd : Conflicts: nscd
 uucpsend : Depends: inn but it is not going to be installed
 wzdftpd-back-mysql : Depends: wzdftpd (= 0.8.3-6.1) but it is not going to be i                                                                             nstalled
 wzdftpd-back-pgsql : Depends: wzdftpd (= 0.8.3-6.1) but it is not going to be i                                                                             nstalled
 wzdftpd-mod-tcl : Depends: wzdftpd (= 0.8.3-6.1) but it is not going to be inst                                                                             alled
 xabacus : Conflicts: xabacus
 xfce4-notifyd : Conflicts: notification-daemon
                 Conflicts: notification-daemon-xfce but 0.3.7-2 is to be instal                                                                             led
 xfswitch-plugin : Depends: gdm but it is not going to be installed or
                            gdm3 but it is not going to be installed
 xmabacus : Conflicts: xabacus
 xnetcardconfig : Depends: pump but it is not going to be installed
E: Broken packages
triton996
 
Сообщений: 27
Зарегистрирован: Вт июн 29, 2010 3:09 pm

Re: Установка sbnc.

Сообщение swg » Ср июл 03, 2013 9:41 pm

Причины
а) viewtopic.php?f=17&t=9257#p47062
б) viewtopic.php?f=9&t=8890&p=45162#p45162
т.е.
а) ставили руками - снести всё, что ставили и использовать официальные репозитории или не использовать совсем и всё собирать руками
б) система управления пакетами лажает

Конец установки c++ не интересен, надо что вы вводили для установки.
swg
флудит форум
 
Сообщений: 2384
Зарегистрирован: Сб окт 07, 2006 9:09 am
Откуда: NNov

Re: Установка sbnc.

Сообщение triton996 » Ср июл 03, 2013 10:30 pm

swg, писал я вот так apt-get install "команда" - а командами были g++,c++,make,gpp
Завтра сделаю как ты написал
triton996
 
Сообщений: 27
Зарегистрирован: Вт июн 29, 2010 3:09 pm

Re: Установка sbnc.

Сообщение swg » Ср июл 03, 2013 10:39 pm

Вспомните, что ставили руками и не забыли ли обновится update; upgrade... проверить конфликты, починить.
Т.к. "checking whether the C++ compiler works... no" - странно, если ставили всё из портов.
И проверьте ./configure у чего-нибудь другого.
swg
флудит форум
 
Сообщений: 2384
Зарегистрирован: Сб окт 07, 2006 9:09 am
Откуда: NNov

Re: Установка sbnc.

Сообщение triton996 » Чт июл 04, 2013 8:34 am

Переустановил Debian. Потом ввел через рут вот эти команды. Все работает отлично. Спасибо swg за помощь.
Код: выделить все
apt-get update
apt-get install nodejs
apt-get install build-essential
triton996
 
Сообщений: 27
Зарегистрирован: Вт июн 29, 2010 3:09 pm

Re: Установка sbnc.

Сообщение DiM- » Чт июл 04, 2013 11:23 am

nodejs для sBNC совсем не нужен
DiM-
 
Сообщений: 19
Зарегистрирован: Пт июн 28, 2013 2:22 pm
Откуда: Екатеринбург


Вернуться в IRC

Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

cron