Страница 1 из 1

Anope 1.8.0 + UnrealIRCD 3.2.7 помогите с Anope

СообщениеДобавлено: Пт ноя 06, 2009 8:03 pm
AK-S
Поставил значит я Anope 1.8.0 и UnrealIRCD 3.2.7, сервер работает исправно, а вот сервисы нехотят, непонимаю почему. Помогите пожалуста...

[b]Вот цитата из лога:[b]
[Nov 06 17:58:58 2009] Loading IRCD Protocol Module: [unreal32]
[Nov 06 17:58:58 2009] status: [0][Module, Okay - No Error]
[Nov 06 17:58:58 2009] Loading Encryption Module: [enc_none]
[Nov 06 17:58:58 2009] status: [0][Module, Okay - No Error]
[Nov 06 17:58:58 2009] Anope 1.8.0 (1899) (ircd protocol: UnrealIRCd 3.2+) starting up
[Nov 06 17:59:01 2009] ms_rsend requested unload...
[Nov 06 17:59:01 2009] debug: trying to load core module [ms_rsend]
[Nov 06 17:59:01 2009] debug: status: [6][Module Error, Error during load time or module returned MOD_STOP]
[Nov 06 17:59:02 2009] MySQL: has been disabled.
[Nov 06 17:59:02 2009] Databases loaded
[Nov 06 17:59:02 2009] Info: Reflecting database records.
[Nov 06 17:59:02 2009] FATAL: Can't connect to server: Connection refused

СообщениеДобавлено: Пт ноя 06, 2009 8:34 pm
AK-S
Всё, то исправил (была ошибка в портах, указал разные в unrealircd.conf и services.conf). Теперь другая ошибка, перепроверил всё тыщу раз, ткните носом в ошибку...

Вот цитата лога:
[Nov 06 18:32:14 2009] Loading IRCD Protocol Module: [unreal32]
[Nov 06 18:32:14 2009] status: [0][Module, Okay - No Error]
[Nov 06 18:32:14 2009] Loading Encryption Module: [enc_none]
[Nov 06 18:32:14 2009] status: [0][Module, Okay - No Error]
[Nov 06 18:32:14 2009] Anope 1.8.0 (1899) (ircd protocol: UnrealIRCd 3.2+) starting up
[Nov 06 18:32:16 2009] ms_rsend requested unload...
[Nov 06 18:32:16 2009] debug: trying to load core module [ms_rsend]
[Nov 06 18:32:16 2009] debug: status: [6][Module Error, Error during load time or module returned MOD_STOP]
[Nov 06 18:32:17 2009] MySQL: has been disabled.
[Nov 06 18:32:17 2009] Databases loaded
[Nov 06 18:32:17 2009] Info: Reflecting database records.
[Nov 06 18:32:17 2009] Connected to Server 1 (127.0.0.1:6669)
[Nov 06 18:32:17 2009] trying to load [cs_appendtopic]
[Nov 06 18:32:17 2009] [cs_appendtopic] Loaded successfully
[Nov 06 18:32:17 2009] status: [0][Module, Okay - No Error]
[Nov 06 18:32:17 2009] trying to load [cs_enforce]
[Nov 06 18:32:17 2009] status: [0][Module, Okay - No Error]
[Nov 06 18:32:17 2009] trying to load [ns_maxemail]
[Nov 06 18:32:17 2009] status: [0][Module, Okay - No Error]
[Nov 06 18:32:17 2009] trying to load [os_info]
[Nov 06 18:32:17 2009] os_info: Loading configuration directives...
[Nov 06 18:32:17 2009] os_info: OSInfoDBName is not defined in Services configuration file, using default os_info.db
[Nov 06 18:32:17 2009] os_info: Directive OSInfoDBName loaded (os_info.db)...
[Nov 06 18:32:17 2009] status: [0][Module, Okay - No Error]
[Nov 06 18:32:17 2009] trying to load [hs_request]
[Nov 06 18:32:17 2009] hs_request loaded
[Nov 06 18:32:17 2009] status: [0][Module, Okay - No Error]
[Nov 06 18:32:17 2009] Error: Your IRCD's link block may not setup correctly, please check unrealircd.conf
[Nov 06 18:32:17 2009] Error: Your IRCD's link block may not setup correctly, please check unrealircd.conf

[Nov 06 18:32:17 2009] Read error from server: Broken pipe (error num: 32)
[Nov 06 18:32:17 2009] [cs_appendtopic] Unloaded successfully
[Nov 06 18:32:17 2009] hs_request un-loaded

СообщениеДобавлено: Пт ноя 06, 2009 8:51 pm
ls
127.0.0.1 не используйте в конфигах, его никто на VDS не слушает так как нет такого интерфейса.

Также имя сервера должно соответствовать обратной записи в DNS (если ничего не меняли, то будет соответсовать)

Учитесь искать с помощью google
http://www.google.ru/search?q=anope+You ... lircd.conf

СообщениеДобавлено: Пт ноя 06, 2009 9:09 pm
AK-S
Что-то недопонял c 127.0.0.1, а что вместо него использовать?!
DNS не менял (я и неумею).

СообщениеДобавлено: Пт ноя 06, 2009 9:51 pm
ls
IP-адрес вашего сервера использовать.
Ну и убедиться что в конфигах верно прописано, правильно прописан порт на который подключаться

СообщениеДобавлено: Пт ноя 06, 2009 9:58 pm
AK-S
Спасибо! Всё работает =) Ввёл IP адрес своего VDS сервера и всё =)))

СообщениеДобавлено: Чт апр 01, 2010 2:25 pm
seiven
ls писал(а):127.0.0.1 не используйте в конфигах, его никто на VDS не слушает так как нет такого интерфейса.


А когда я ирк поднимал на вдс, у меня на локалхосте всё работало :P

СообщениеДобавлено: Чт апр 01, 2010 6:09 pm
ls
На Linux и FreeBSD 8 можно использовать