PHP extensions

панель управления сервером, общие и любые другие вопросы не нашедшие подходящего форума

Модератор: Art.i

PHP extensions

Сообщение Flector » Ср авг 31, 2016 5:53 pm

centos 7 with ispmanager5.

пара вопросов:

не могу найти, где подключаются extensions. в php.ini такого раздела нет.
просто установил APC для PHP, а подключение через файл apc.ini в etc/php.d выбивает ошибку про то, что модуль уже подключен.
так вот не могу найти конфиг, куда ISPManager запихнул включение APC (так как именно в панели включал APC).

и да - APC собирал из исходников, мне это не понравилось - в каком репозитории можно найти APC для centos 7?
Flector
 
Сообщений: 80
Зарегистрирован: Пн июн 18, 2012 10:22 am

Re: PHP extensions

Сообщение Mikanoshi » Чт сен 01, 2016 2:06 am

Код: выделить все
<? phpinfo(); ?>

Пункт "Scan this dir for additional .ini files".
Flector писал(а):APC собирал из исходников, мне это не понравилось

Вот это заявление)) Компиляция из исходников это расово верное решение на никс системах.
Кстати, зачем APC, PHP древний? Для новых же лучше opcache, и APCu для юзеркеша.

P.S. От ISPManager-а лучше отвыкать, изучать консоль, будет меньше непоняток)
Код: выделить все
php -i | egrep "\.ini|extension"
Mikanoshi
 
Сообщений: 205
Зарегистрирован: Сб май 02, 2009 2:03 pm

Re: PHP extensions

Сообщение Flector » Чт сен 01, 2016 7:30 am

нашел, где оно подключалось - в ispmgr.ini, как-то не сразу обратил внимание.

Mikanoshi писал(а):Вот это заявление)) Компиляция из исходников это расово верное решение на никс системах.
Кстати, зачем APC, PHP древний? Для новых же лучше opcache, и APCu для юзеркеша.


версии php 5.4.16 - что по умолчанию на vds есть. меня устраивает.

по поводу компиляции - для компиляции маленького модуля пришлось установить и обновить кучу всего, аж на 72мб.
сдается мне, что это не "расово верное решение", когда для одного модуля обновляется куча зависимостей, что потенциально может привести к конфликтам.
Flector
 
Сообщений: 80
Зарегистрирован: Пн июн 18, 2012 10:22 am

Re: PHP extensions

Сообщение Mikanoshi » Чт сен 01, 2016 8:13 pm

Flector писал(а):когда для одного модуля обновляется куча зависимостей, что потенциально может привести к конфликтам.

Надо правильно обновлять, тогда не приведёт) Как раз установка без обновления зависимостей скорее всего вызовет конфликты.
В портах исходники последних версий, а в пакетах не всегда, в остальном разницы быть не должно, pkg пакеты зависимостей точно так же подтянет, если нужно.
Mikanoshi
 
Сообщений: 205
Зарегистрирован: Сб май 02, 2009 2:03 pm


Вернуться в ISPmanager

Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 3