Страница 1 из 1

Не заходится в PhpPgAdmin с правами pgsql

СообщениеДобавлено: Вс май 18, 2008 2:36 pm
webserfer
Когда я пытаюсь залогиниться в PhpPgAdmin с логином pgsql
мне пишут: Логин недопустим по соображениям безопасности
Как разрешить заход с этого логина?

СообщениеДобавлено: Пн май 19, 2008 8:43 pm
Kein
Правь конфиг PhpPgAdmin. Насколь я помню - там это блокируется/разрешается.

СообщениеДобавлено: Чт май 22, 2008 1:44 am
webserfer
Не подскажешь где он находится?

СообщениеДобавлено: Чт май 22, 2008 1:49 pm
Kein
Там, где он у тебя установлен. Файл конфига называется config.inc.php и должен быть в корневой директории продукта. А опция следующая:
// If extra login security is true, then logins via phpPgAdmin with no
// password or certain usernames (pgsql, postgres, root, administrator)
// will be denied. Only set this false once you have read the FAQ and
// understand how to change PostgreSQL's pg_hba.conf to enable
// passworded local connections.
$conf['extra_login_security'] = true;

СообщениеДобавлено: Чт май 22, 2008 11:19 pm
webserfer
Ну и где же он утановлен))))) в /usr/local/pgsql такого файла нету(

Видимо это зависит от оси? у меня фрюшка

СообщениеДобавлено: Пт май 23, 2008 2:38 pm
leonidas
webserfer писал(а):Ну и где же он утановлен))))) в /usr/local/pgsql такого файла нету(

Видимо это зависит от оси? у меня фрюшка


У меня тоже фря… но pgsql и phpPgAdmin это очень похоже, но не одно и тоже. первое это сервер, а второе — клиент

Ищите и найдёте… (Св. Ев. от Матфея 7:7)


Код: выделить все
# cat /usr/local/www/phpPgAdmin/conf/config.inc.php | grep login
        // Display name for the server on the login screen
        // If extra login security is true, then logins via phpPgAdmin with no
//      $conf['extra_login_security'] = true;
        $conf['extra_login_security'] = false;

СообщениеДобавлено: Пт май 23, 2008 4:36 pm
webserfer
Спасибо!