Страница 1 из 1

Разные версии PHP для двух доменов

СообщениеДобавлено: Пт май 09, 2014 10:58 am
Mike05
Сервер FreeBSD 8.4-STABLE (ISPmanager-Lite)
Для основного домена работает PHP 5.2, и апгрейдить его нельзя (несовместим софт). Стоит php как модуль апача.
Мне нужно для другого домена, чтобы работал PHP 5.4.
Подскажите, пожалуйста, как это настроить. Если нельзя модуль апача, может там прописать php как cgi или еще что-то, не очень в этом разбираюсь, а сделать надо.

Re: Разные версии PHP для двух доменов

СообщениеДобавлено: Пт май 09, 2014 1:22 pm
ls
Как вариант, собрать PHP нужной версии вручную из исходников в отдельный каталог (скажем в /opt/php) и включив для домена PHP в режиме как CGI исправить путь в файле ~/php-bin/php (в директории пользователя) к интерпретатору