Разные версии PHP для двух доменов

Вопросы связанные с работой Apache

Модераторы: Art.i, vasya

Разные версии PHP для двух доменов

Сообщение Mike05 » Пт май 09, 2014 10:58 am

Сервер FreeBSD 8.4-STABLE (ISPmanager-Lite)
Для основного домена работает PHP 5.2, и апгрейдить его нельзя (несовместим софт). Стоит php как модуль апача.
Мне нужно для другого домена, чтобы работал PHP 5.4.
Подскажите, пожалуйста, как это настроить. Если нельзя модуль апача, может там прописать php как cgi или еще что-то, не очень в этом разбираюсь, а сделать надо.
Mike05
 
Сообщений: 18
Зарегистрирован: Сб мар 05, 2011 3:43 pm

Re: Разные версии PHP для двух доменов

Сообщение ls » Пт май 09, 2014 1:22 pm

Как вариант, собрать PHP нужной версии вручную из исходников в отдельный каталог (скажем в /opt/php) и включив для домена PHP в режиме как CGI исправить путь в файле ~/php-bin/php (в директории пользователя) к интерпретатору
* FirstVDS в twitter в facebook и в вконтакте *
ls
Support team
 
Сообщений: 6390
Зарегистрирован: Чт мар 01, 2007 10:36 am
Откуда: FirstVDS


Вернуться в Apache

Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 2