переустановить апач

Вопросы связанные с работой Apache

Модераторы: Art.i, vasya

переустановить апач

Сообщение wbread » Чт янв 16, 2014 5:55 pm

Попытался переустановить апач. При стандартном способе через ИСП админку возникли ошибки
running 'apt-get purge libapache2-mod-rpaf':
Reading package lists...
Building dependency tree...
Reading state information...
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
libt1-5 : Depends: libx11-6 but it is not going to be installed
php5-gd : Depends: libgd2-xpm (>= 2.0.36~rc1~dfsg) but it is not going to be installed
Depends: libx11-6 but it is not going to be installed
Depends: libxpm4 but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
Type: 'pkg_ctlfailed' Object: '' Value: 'uninstall: error uninstalling package 'libapache2-mod-rpaf'
'

не удалить не переустановить теперь не могу. при попытке apt-get -f install
система выдает еще
root@хххххх:~# apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
libgd2-xpm libx11-6 libxau6 libxcb1 libxdmcp6 libxpm4
Suggested packages:
libgd-tools
The following NEW packages will be installed:
libgd2-xpm libx11-6 libxau6 libxcb1 libxdmcp6 libxpm4
0 upgraded, 6 newly installed, 0 to remove and 0 not upgraded.
4 not fully installed or removed.
Need to get 0 B/1203 kB of archives.
After this operation, 2662 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
dpkg: error processing /var/cache/apt/archives/libxau6_1%3a1.0.6-1_amd64.deb (--unpack):
libxau6:amd64 1:1.0.6-1 (Multi-Arch: no) is not co-installable with libxau6 which has multiple installed instances
dpkg: error processing /var/cache/apt/archives/libxdmcp6_1%3a1.0.3-2_amd64.deb (--unpack):
libxdmcp6:amd64 1:1.0.3-2 (Multi-Arch: no) is not co-installable with libxdmcp6 which has multiple installed instances
dpkg: error processing /var/cache/apt/archives/libxcb1_1.6-1+squeeze1_amd64.deb (--unpack):
libxcb1:amd64 1.6-1+squeeze1 (Multi-Arch: no) is not co-installable with libxcb1 which has multiple installed instances
dpkg: error processing /var/cache/apt/archives/libx11-6_2%3a1.3.3-4+squeeze1_amd64.deb (--unpack):
libx11-6:amd64 2:1.3.3-4+squeeze1 (Multi-Arch: no) is not co-installable with libx11-6 which has multiple installed instances
dpkg: error processing /var/cache/apt/archives/libxpm4_1%3a3.5.8-1_amd64.deb (--unpack):
libxpm4:amd64 1:3.5.8-1 (Multi-Arch: no) is not co-installable with libxpm4 which has multiple installed instances
dpkg: error processing /var/cache/apt/archives/libgd2-xpm_2.0.36~rc1~dfsg-5_amd64.deb (--unpack):
libgd2-xpm:amd64 2.0.36~rc1~dfsg-5 (Multi-Arch: no) is not co-installable with libgd2-xpm which has multiple installed instances
Errors were encountered while processing:
/var/cache/apt/archives/libxau6_1%3a1.0.6-1_amd64.deb
/var/cache/apt/archives/libxdmcp6_1%3a1.0.3-2_amd64.deb
/var/cache/apt/archives/libxcb1_1.6-1+squeeze1_amd64.deb
/var/cache/apt/archives/libx11-6_2%3a1.3.3-4+squeeze1_amd64.deb
/var/cache/apt/archives/libxpm4_1%3a3.5.8-1_amd64.deb
/var/cache/apt/archives/libgd2-xpm_2.0.36~rc1~dfsg-5_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
wbread
 
Сообщений: 66
Зарегистрирован: Вт апр 29, 2008 5:26 pm

Re: переустановить апач

Сообщение ls » Пт янв 17, 2014 6:54 am

Выполните apt-get update и затем apt-get install libx11-6
* FirstVDS в twitter в facebook и в вконтакте *
ls
Support team
 
Сообщений: 6390
Зарегистрирован: Чт мар 01, 2007 10:36 am
Откуда: FirstVDS

Re: переустановить апач

Сообщение wbread » Пт янв 17, 2014 11:14 am

root@xxx:~# apt-get install libx11-6
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
libx11-6 : Depends: libxcb1 (>= 1.2) but it is not going to be installed
php5-gd : Depends: libgd2-xpm (>= 2.0.36~rc1~dfsg) but it is not going to be installed
Depends: libxpm4 but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
wbread
 
Сообщений: 66
Зарегистрирован: Вт апр 29, 2008 5:26 pm

Re: переустановить апач

Сообщение wbread » Пт янв 17, 2014 1:01 pm

после долги мучений вроде как он удалился, при попытке поставить его средствами ИСП панели выдает ошибку:
При настройке Web-сервера возникла ошибка: невозможно завершить настройку web-сервера - модуль 'web' не загружен. Не установлен ни один web-сервер или Web-сервер не удается запустить. Пожалуйста, (пере)установите Web-сервер.
wbread
 
Сообщений: 66
Зарегистрирован: Вт апр 29, 2008 5:26 pm


Вернуться в Apache

Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 2