Проблема с некоторыми расширениями PHP

Вопросы связанные с работой Apache

Модераторы: Art.i, vasya

Проблема с некоторыми расширениями PHP

Сообщение unstaller » Пт янв 14, 2011 10:32 am

Добрый день. Устанавливал сегодня на сервер расширение ioncube и случайно обнаружил ошибки с некоторыми расширениями.

в частности, запустив в терминале команду php -m перед выводом списка установленных расширений он выдал такие вот строки

PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20060613/php_xsl.dll' - Cannot open "/usr/local/lib/php/20060613/php_xsl.dll" in Unknown on line 0

PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20060613/libxml.so' - Cannot open "/usr/local/lib/php/20060613/libxml.so" in Unknown on line 0

PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20060613/cgi-fcgi.so' - Cannot open "/usr/local/lib/php/20060613/cgi-fcgi.so" in Unknown on line 0

PHP Warning: Module 'iconv' already loaded in Unknown on line 0

PHP Warning: Module 'dom' already loaded in Unknown on line 0

PHP Warning: Module 'xsl' already loaded in Unknown on line 0

По первым 3м ошибкам проверил, действительно нет файлов данных расширений, а последние 3 вообще не понял что это такое.

Подскажите может кто знает как справиться с этими ошибками. По сути то сервер работает , однако когда такие ошибки это ж тоже не серьезно :)
unstaller
 
Сообщений: 14
Зарегистрирован: Пт мар 12, 2010 4:53 pm

Сообщение ls » Пт янв 14, 2011 12:40 pm

Удалить несуществующие расширения PHP из /usr/local/etc/php/extensions.ini
* FirstVDS в twitter в facebook и в вконтакте *
ls
Support team
 
Сообщений: 6405
Зарегистрирован: Чт мар 01, 2007 10:36 am
Откуда: FirstVDS


Вернуться в Apache

Кто сейчас на форуме

Сейчас этот форум просматривают: Google [Bot] и гости: 1