Страница 1 из 1

Внезапно: Forbidden 403

СообщениеДобавлено: Пт окт 15, 2010 4:10 am
Teimos
В общем у меня проблема. Использую curl в скрипте, все работало нормально. Потом потребовалось в курле использовать CURLOPT_FOLLOWLOCATION, но не тут то было! Появилась ошибка, что то типа safe_mode включен или open_basedir утановлен, типа курл так работать не хочет. Проверил safe_mode - там off, все нормально. Далее в httpd.conf вырубил opeb_basedir вот так:

php_admin_value open_basedir none

Перезагрузил сервер, запустил скрипт, все нормально. Было. Через несколько минут абсолютно правильной работы скрипта ВНЕЗАПНО сервер стал отдавать оибку 403. И отдает до сих пор, никакие скрипты и директории из браузера недоступны.

В error.log пишет следующее:
Symbolic link not allowed or link target not accessible

Что делать, как жить дальше? Я в депрессии =(

СообщениеДобавлено: Сб окт 16, 2010 10:48 pm
ls
Обновление ISPmanager настроило параметры в файле secure.conf как
Код: выделить все
Options +Includes -FollowSymLinks +SymLinksIfOwnerMatch

теперь если используются в директории пользователя символические ссылки и владелец не пользователь владелец хоста то переход по ним не работает.
Надо или поменять владельца симлинка следующей командой (без / в конце, выполнять необходимо с правами root)
Код: выделить все
chown -h пользователь имя_symlink

Либо исправить secure.conf чтобы выглядела строка как
Код: выделить все
Options +Includes +FollowSymLinks

Путь к файлу secure.conf в системах
FreeBSD: /usr/local/etc/apache22/Includes/secure.conf
Debian и Ubuntu: /etc/apache2/conf.d/secure.conf
CentOS и Fedora: /etc/httpd/conf.d/secure.conf

После правки необходимо перезапустить Apache командой apachectl restart или (в Debian) apache2ctl restart

Или пишите в поддержку - вам настроят.