Временно вернуть Apache и ISPmanager

Вопросы связанные с работой Apache

Модераторы: Art.i, vasya

Временно вернуть Apache и ISPmanager

Сообщение BelStudent » Вс апр 19, 2009 4:47 pm

У меня стоит: nginx+php-fpm. Понадобилось на время воспользоваться ISPmanagerom, для этого пытаюсь запустить Apache:
Код: выделить все
/usr/local/etc/rc.d/apache22 start

в результате ничего, никаких сообщений.
Попробывал
Код: выделить все
apachectl startssl

Но выдало:
The startssl option is no longer supported.
Please edit httpd.conf to include the SSL configuration settings
and then use apachectl start.
Вроде бы понятно написано, но я не трогал httpd.conf почему в нём изменились настройки?
Тогда я попробывал
Код: выделить все
apachectl start

Результат:
Syntax error on line 491 of /usr/local/etc/apache22/httpd.conf:
Invalid command 'php_admin_value', perhaps misspelled or defined by a module not included in the server configuration.
Опять повторю, я не трогал файл настроек апача. Перед тем как установить nginx, я остановил apache и убрал из автозагрузки (т.е. rc.conf поставил:apache22_enable="NO").
Как же мне сейчас запустить apache, чтобы заработал ISPmanager?
BelStudent
 
Сообщений: 27
Зарегистрирован: Чт мар 05, 2009 10:05 pm

Сообщение ls » Вс апр 19, 2009 7:23 pm

Syntax error on line 491 of /usr/local/etc/apache22/httpd.conf:
Invalid command 'php_admin_value', perhaps misspelled or defined by a module not included in the server configuration.


У вас в конфиге apache не подключен libphp5.so (модуль для работы PHP как модуль Apache), видимо это возникло потому, что вы удалили обычный PHP и собрали php-fpm

Отредактируйте конфиг apache и уберите оттуда директивы относящиеся к работе PHP как модуль apache, в вашем случае можно просто в 491 строке закоментировать знаком # и далее где будет ругаться.

Apache 2.2 надо запускать как apachectl start - startssl это для apache 1.3, скрипт автозагрузки /usr/local/etc/rc.d/apache22 не отрабатывает потому что в rc.conf отключено, посмотрите скрипт - он хочет чтобы было apache22_enable="YES", вот и не отрабатывает.
ls
Support team
 
Сообщений: 6405
Зарегистрирован: Чт мар 01, 2007 10:36 am
Откуда: FirstVDS

Сообщение Anton Bulkin » Ср июн 17, 2009 12:11 am

У меня стоит сервер nginx и php-fpm. Аналогично, понадобился ispmanager.

на команду apachectl start получаю ошибку: Address already in use: make_sock: could not bind to address 0.0.0.0:443
no listening sockets available, shutting down
Unable to open logs
Anton Bulkin
 
Сообщений: 17
Зарегистрирован: Пн июн 15, 2009 2:47 pm
Откуда: Deutchland

Сообщение art » Ср июн 17, 2009 3:27 am

>Address already in use: make_sock: could not bind to address 0.0.0.0:443

Говорит что 443 порт у Вас уже занят и потому apache не может запуститься
art
Support team
 
Сообщений: 798
Зарегистрирован: Вс июн 11, 2006 2:37 am

Сообщение ls » Ср июн 17, 2009 8:23 am

Команда
Код: выделить все
sockstat | grep 443

во FreeBSD или
Код: выделить все
netstat -nap | grep 443

в линуксе покажет кем занят 443 порт (каким процессом), в данный момент, возможно nginxом занят (его можно так настроить раскомментировав в дефолтном конфиге лишнее)
ls
Support team
 
Сообщений: 6405
Зарегистрирован: Чт мар 01, 2007 10:36 am
Откуда: FirstVDS

Сообщение Anton Bulkin » Ср июн 17, 2009 11:28 am

ls писал(а):... в данный момент, возможно nginxом занят (его можно так настроить раскомментировав в дефолтном конфиге лишнее)


Так и есть:
Код: выделить все
www      nginx      48993 8  tcp4   *:443                 *:*
www      nginx      48992 8  tcp4   *:443                 *:*
root     nginx      48991 8  tcp4   *:443                 *:*
Anton Bulkin
 
Сообщений: 17
Зарегистрирован: Пн июн 15, 2009 2:47 pm
Откуда: Deutchland

Сообщение ls » Ср июн 17, 2009 11:39 am

Поправьте конфиг nginx чтобы он не слушал 443 порт
ls
Support team
 
Сообщений: 6405
Зарегистрирован: Чт мар 01, 2007 10:36 am
Откуда: FirstVDS

Сообщение Anton Bulkin » Ср июн 17, 2009 12:27 pm

ls писал(а):Поправьте конфиг nginx чтобы он не слушал 443 порт


конфиг nginx? Сменить на другой порт?
Anton Bulkin
 
Сообщений: 17
Зарегистрирован: Пн июн 15, 2009 2:47 pm
Откуда: Deutchland

Сообщение ls » Ср июн 17, 2009 12:31 pm

Anton Bulkin писал(а):
ls писал(а):Поправьте конфиг nginx чтобы он не слушал 443 порт


конфиг nginx? Сменить на другой порт?
Да, можно поправить в конфиге nginx, только не совсем понятно зачем он у вас 443 порт слушает, у сайтов есть https и это настроено в нем?
ls
Support team
 
Сообщений: 6405
Зарегистрирован: Чт мар 01, 2007 10:36 am
Откуда: FirstVDS

Сообщение ls » Ср июн 17, 2009 12:45 pm

Лучше конфиг nginx не ломайте (если там сайты настроены так), а поменяйте порт 443 на другой в конфигурации apache и заходите через другой порт в ISPmanager
ls
Support team
 
Сообщений: 6405
Зарегистрирован: Чт мар 01, 2007 10:36 am
Откуда: FirstVDS

Сообщение Anton Bulkin » Ср июн 17, 2009 12:47 pm

ls писал(а):Да, можно поправить в конфиге nginx, только не совсем понятно зачем он у вас 443 порт слушает, у сайтов есть https и это настроено в нем?


Nginx слушает 443, так как нужен https. И это прописано в ngnix.conf вот здесь:

Код: выделить все
    server {
   listen       443;

   ssl on;
   ssl_protocols        SSLv3 TLSv1;
Anton Bulkin
 
Сообщений: 17
Зарегистрирован: Пн июн 15, 2009 2:47 pm
Откуда: Deutchland

Сообщение Anton Bulkin » Ср июн 17, 2009 3:36 pm

ls писал(а):Лучше конфиг nginx не ломайте (если там сайты настроены так), а поменяйте порт 443 на другой в конфигурации apache и заходите через другой порт в ISPmanager


Да, согласен.
Залез в httpd.conf и httpd-ssl.conf и поменял везде порты с 443 на 44.
Потом:

Код: выделить все
func# apachectl start
[warn] (2)No such file or directory: Failed to enable the 'httpready' Accept Filter
[warn] (2)No such file or directory: Failed to enable the 'httpready' Accept Filter

:(

Допустим, если апач запустится. Как адрес ispmanager будет выглядеть на новом 44 порте?
Anton Bulkin
 
Сообщений: 17
Зарегистрирован: Пн июн 15, 2009 2:47 pm
Откуда: Deutchland

Сообщение LimpTeaM » Ср июн 17, 2009 3:38 pm

Anton Bulkin писал(а):
ls писал(а):Лучше конфиг nginx не ломайте (если там сайты настроены так), а поменяйте порт 443 на другой в конфигурации apache и заходите через другой порт в ISPmanager


Да, согласен.
Залез в httpd.conf и httpd-ssl.conf и поменял везде порты с 443 на 44.
Потом:

Код: выделить все
func# apachectl start
[warn] (2)No such file or directory: Failed to enable the 'httpready' Accept Filter
[warn] (2)No such file or directory: Failed to enable the 'httpready' Accept Filter

:(

Допустим, если апач запустится. Как адрес ispmanager будет выглядеть на новом 44 порте?

это варнинг и мешать не должен.
строка должна выглядеть что-то типа http://ip:44/manager
LimpTeaM
 
Сообщений: 1
Зарегистрирован: Вт апр 15, 2008 9:36 am

Сообщение Anton Bulkin » Ср июн 17, 2009 4:06 pm

LimpTeaM писал(а):это варнинг и мешать не должен.
строка должна выглядеть что-то типа http://ip:44/manager


Безрезультатно.

Может 8080 порт нужно менять?
Anton Bulkin
 
Сообщений: 17
Зарегистрирован: Пн июн 15, 2009 2:47 pm
Откуда: Deutchland

Сообщение ls » Ср июн 17, 2009 4:16 pm

Напишите в поддержку, посмотрим что у вас случилось и сделаем что работал ispmanager на отдельном порту

с ссылкой на этот топик
ls
Support team
 
Сообщений: 6405
Зарегистрирован: Чт мар 01, 2007 10:36 am
Откуда: FirstVDS

След.

Вернуться в Apache

Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

cron